Problem wit DI resin

jd371

Member
Rating - 0%
0   0   0
Location
Levittown
I was going to replace the DI last night, but after I installed the new DI resin I was getting 5ppm when I tested the water. I let it run for about a half hour and it still was showing 5ppm from the output. The only difference this time is I used an already packed container instead of packing it with DI resin manually like last time. I tried a few times of removing and replacing thinking it wasn't seated properly but that didn't help. I installed the old one back and it was back to 0ppm on the output. The old DI is almost exhausted there is not much of the original color left so I will need to replace it soon. Anybody else experience this and if so what did you do?
 

jd371

Member
Rating - 0%
0   0   0
Location
Levittown
I recently had to do a full sanitize treatment, replace DI and then double check my TDS meter pins were fully inserted to finally get mine to read 0.

Check those

Here is the link to sanitizing your RO/DI system:
http://www.reefcentral.com/forums/showthread.php?t=1941955
Thanks for the link. I've never sanitized my system in the two years I've had it, I never thought about it. Next time I'm replacing the filters I will sanitize.
 

evoIX_Reefer

Active member
Rating - 100%
124   0   0
I've never done it before. Found it when I was having issues as well. Did it, reseeded everything and perfect 0.

I would do it if you have the time. Only takes a 1 hour to complete the whole task.
 

jd371

Member
Rating - 0%
0   0   0
Location
Levittown
DI resin doesnt have a long shelf life after opening.
Although the original package with the three filters was opened last year, the DI resin was still sealed until I opened it last week. Doesn't matter now it's toast because it's been sitting out since last week when I installed the original DI cartridge because the new one was giving me 5ppm.
I ordered some DI resin to pack the cartridge myself like last time.
 

Featured Sponsors


Top